January 27th, 2008

nepal

сеть узлом

Сам не понял, что я такого сделал, но вот так разухабисто вдруг у меня сеть стала работать:

$ ping video.mipt.ru
PING video.mipt.ru (194.85.82.7) 56(84) bytes of data.
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=3 ttl=62 time=1840 ms
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=3 ttl=62 time=2353 ms (DUP!)
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=3 ttl=62 time=2432 ms (DUP!)
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=5 ttl=62 time=341 ms
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=5 ttl=62 time=341 ms (DUP!)
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=4 ttl=62 time=1884 ms
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=4 ttl=62 time=2660 ms (DUP!)
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=6 ttl=62 time=900 ms
64 bytes from video.mipt.ru (194.85.82.7): icmp_seq=7 ttl=62 time=415 ms

--- video.mipt.ru ping statistics ---
7 packets transmitted, 5 received, +4 duplicates, 28% packet loss, time 6166ms
rtt min/avg/max/mdev = 341.055/1463.384/2660.352/907.697 ms, pipe 3


Есть идеи, как такое можно создать искусственно (на клиенте)?
nepal

[всё ещё] поднимаем роутер на CentOS 5.1

Какая-то мистерия. Вай-фай карточка на чипсете Atheros, драйверьё (madwifi) поставил, поднял в режиме Master (то есть как Access Point), а iwconfig говорит, что 802.11b, и никак не меняется, хоть ты тресни. И, главное, ноут эту карточку не видит.

Так оно у меня стояло неделю. Я уже думал, что-то с железом случилось, или madwifi какой-нибудь неработающей версии, или центосное ядро как-то не дружит с этим драйвером, или фаза луны не та. Сильно горевал, расстраивался, опускал руки.

Сегодня сподобился сделать второй подход. Все симптомы те же. И тут индеец зоркий глаз заметил (в выводе /sbin/ip a), что интерфейс не в UP. Сказал ifconfig ath0 up (что, наверное, является аналогом /sbin/ip link set ath0 up), и тут случилось чудо -- 802.11b вдруг стало 802.11g, ноут стал видеть девайс, и всё такое.