May 5th, 2008

nepal

сайт билайна

Сайт uslugi.beeline.ru. Внизу страницы написано:

Для корректной работы в системе используйте версию браузера Internet Explorer не ниже 6.0.

И точно! Имея Firefox 2.0.0.14, изменить свои данные не могу, даже кнопки не нажимаются. 2007 2008 год на дворе, блин...